$re = '/^(\d\s?(?:\(\d{3}\))?\s?[\d|\-]{8,12})$/m';
$str = '1 (555) 555-5555
5555555555
1 555-555-5555
555-555-5555
and not:
1 555)555-5555
(6505552368)
10 (757) 622-7382
555)-555-5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);