// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d\s?(?:\(\d{3}\))?\s?[\d|\-]{8,12})$").unwrap();
let string = "1 (555) 555-5555
5555555555
1 555-555-5555
555-555-5555
and not:
1 555)555-5555
(6505552368)
10 (757) 622-7382
555)-555-5555";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}