using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)(ich|ja|das|für|und|nein|doch|bock|kopf|lust|schnell|weg|zug|frei|bald|echt|klar|laut|nass|süß|toll|witz|ziel|haar|haus|wort|zeit|schatz|funk|glück|kuss|maus|nacht|paar|rund|satz|tage|ufer|viel|wald|welt|zahn|zelt|bunt|dorf)(?=\s)";
string input = @"How many of you have a Colin Robinson in your life? Someone who drags out conversations for as long as they can after you say,
""I gotta go, dude."" Someone who asks you for favors they never return. Someone who will talk so fast in rambling sentences that you can't get in a word edgewise when you are just talking to them.
An energy vampire? I think I finally got rid of my Colin Robinson today! (Image)
Quand tu es chauve, qu'il fait-5°c, et que tu as oublié ton bonnet. #memecredi (Image)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}