import Foundation
let pattern = #"(?<=\s)(ich|ja|das|für|und|nein|doch|bock|kopf|lust|schnell|weg|zug|frei|bald|echt|klar|laut|nass|süß|toll|witz|ziel|haar|haus|wort|zeit|schatz|funk|glück|kuss|maus|nacht|paar|rund|satz|tage|ufer|viel|wald|welt|zahn|zelt|bunt|dorf)(?=\s)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
How many of you have a Colin Robinson in your life? Someone who drags out conversations for as long as they can after you say,
"I gotta go, dude." Someone who asks you for favors they never return. Someone who will talk so fast in rambling sentences that you can't get in a word edgewise when you are just talking to them.
An energy vampire? I think I finally got rid of my Colin Robinson today! (Image)
Quand tu es chauve, qu'il fait-5°c, et que tu as oublié ton bonnet. #memecredi (Image)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)