import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s)(ich|ja|das|für|und|nein|doch|bock|kopf|lust|schnell|weg|zug|frei|bald|echt|klar|laut|nass|süß|toll|witz|ziel|haar|haus|wort|zeit|schatz|funk|glück|kuss|maus|nacht|paar|rund|satz|tage|ufer|viel|wald|welt|zahn|zelt|bunt|dorf)(?=\\s)";
final String string = "How many of you have a Colin Robinson in your life? Someone who drags out conversations for as long as they can after you say,\n"
+ "\"I gotta go, dude.\" Someone who asks you for favors they never return. Someone who will talk so fast in rambling sentences that you can't get in a word edgewise when you are just talking to them.\n"
+ "An energy vampire? I think I finally got rid of my Colin Robinson today! (Image)\n\n\n"
+ "Quand tu es chauve, qu'il fait-5°c, et que tu as oublié ton bonnet. #memecredi (Image)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}