#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"(https?:\/\/[^"\s]+\/\S+?\.jpg[^"\s]*)""
Local $sString = ""https://text/text/.../text.jpg?text=text&text=..."" & @CRLF & _
""https://text/text/.../text.jpg?t&ext=text&text=..."" & @CRLF & _
""https://text/text/.../text.jpg?text=text""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")