package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(https?:\/\/[^"\s]+\/\S+?\.jpg[^"\s]*)"`)
var str = `"https://text/text/.../text.jpg?text=text&text=..."
"https://text/text/.../text.jpg?t&ext=text&text=..."
"https://text/text/.../text.jpg?text=text"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}