$re = '/"(https?:\/\/[^"\s]+\/\S+?\.jpg[^"\s]*)"/m';
$str = '"https://text/text/.../text.jpg?text=text&text=..."
"https://text/text/.../text.jpg?t&ext=text&text=..."
"https://text/text/.../text.jpg?text=text"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);