import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(https?:\\/\\/[^\"\\s]+\\/\\S+?\\.jpg[^\"\\s]*)\"";
final String string = "\"https://text/text/.../text.jpg?text=text&text=...\"\n"
+ "\"https://text/text/.../text.jpg?t&ext=text&text=...\"\n"
+ "\"https://text/text/.../text.jpg?text=text\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}