#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{14}$)[A-Za-z0-9]{1,4} *\d{10}"
Local $sString = "A12B1234567890" & @CRLF & _
"AB1 1234567890" & @CRLF & _
"AB 1234567890" & @CRLF & _
"" & @CRLF & _
"AB1 1234567890" & @CRLF & _
"A1B1234567890" & @CRLF & _
"A1 B1234567890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")