const regex = /^(?=.{14}$)[A-Za-z0-9]{1,4} *\d{10}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{14}$)[A-Za-z0-9]{1,4} *\\d{10}', 'gm')
const str = `A12B1234567890
AB1 1234567890
AB 1234567890
AB1 1234567890
A1B1234567890
A1 B1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}