re = /^(?=.{14}$)[A-Za-z0-9]{1,4} *\d{10}/m
str = 'A12B1234567890
AB1 1234567890
AB 1234567890
AB1 1234567890
A1B1234567890
A1 B1234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end