use strict;
my $str = 'A12B1234567890
AB1 1234567890
AB 1234567890
AB1 1234567890
A1B1234567890
A1 B1234567890';
my $regex = qr/^(?=.{14}$)[A-Za-z0-9]{1,4} *\d{10}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}