import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s[A-Z]\\.).+?(?=(\\s[A-Z]\\.)|(\\W?(Answer:)\\W?))";
final String string = "1. Question goes here:\n"
+ "A. Answer one\n"
+ "B. Answer two \n"
+ "C. Answer three D. Not indented Answer\n"
+ "Answer: B is correct";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}