import re
regex = re.compile(r"(\s[A-Z]\.).+?(?=(\s[A-Z]\.)|(\W?(Answer:)\W?))")
test_str = ("1. Question goes here:\n"
"A. Answer one\n"
"B. Answer two \n"
"C. Answer three D. Not indented Answer\n"
"Answer: B is correct")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")