$re = '/(\s[A-Z]\.).+?(?=(\s[A-Z]\.)|(\W?(Answer:)\W?))/';
$str = '1. Question goes here:
A. Answer one
B. Answer two
C. Answer three D. Not indented Answer
Answer: B is correct';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);