const regex = new RegExp('(?<!\\be\\.g)\\.(?=\\s+\\p{Lu})', 'ui')
const str = `cats, e.g. Barsik, are funny. And it is true. So,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}