re = /(?<!\be\.g)\.(?=\s+\p{Lu})/i
str = 'cats, e.g. Barsik, are funny. And it is true. So,'
# Print the match result
str.match(re) do |match|
puts match.to_s
end