$re = '~(?<!\be\.g)\.(?=\s+\p{Lu})~ui';
$str = 'cats, e.g. Barsik, are funny. And it is true. So,';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);