#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)filename[^;\n=]*=(['\"])*(?:utf-8\'\')?(.*)(?(1)\1|)"
Local $sString = "attachment; filename=content.txt" & @CRLF & _
"attachment; filename*=UTF-8''filename.txt" & @CRLF & _
"attachment; filename="EURO rates"; filename*=utf-8''%e2%82%ac%20rates" & @CRLF & _
"attachment; filename="omáèka.jpg""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")