using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"filename[^;\n=]*=(['\""])*(?:utf-8\'\')?(.*)(?(1)\1|)";
string input = @"attachment; filename=content.txt
attachment; filename*=UTF-8''filename.txt
attachment; filename=""EURO rates""; filename*=utf-8''%e2%82%ac%20rates
attachment; filename=""omáèka.jpg""";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}