# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"filename[^;\n=]*=(['\"])*(?:utf-8\'\')?(.*)(?(1)\1|)"
test_str = ("attachment; filename=content.txt\n"
"attachment; filename*=UTF-8''filename.txt\n"
"attachment; filename=\"EURO rates\"; filename*=utf-8''%e2%82%ac%20rates\n"
"attachment; filename=\"omáèka.jpg\"")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.