import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "filename[^;\\n=]*=(['\\\"])*(?:utf-8\\'\\')?(.*)(?(1)\\1|)";
final String string = "attachment; filename=content.txt\n"
+ "attachment; filename*=UTF-8''filename.txt\n"
+ "attachment; filename=\"EURO rates\"; filename*=utf-8''%e2%82%ac%20rates\n"
+ "attachment; filename=\"omáèka.jpg\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}