#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]+(?:\.(?![km]))?\d*[km]?$"
Local $sString = "400k" & @CRLF & _
"400.2k" & @CRLF & _
"4m" & @CRLF & _
"500." & @CRLF & _
"500000" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"4.2.k" & @CRLF & _
".3k" & @CRLF & _
"4...k" & @CRLF & _
"300.k"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")