re = /^[0-9]+(?:\.(?![km]))?\d*[km]?$/m
str = '400k
400.2k
4m
500.
500000
4.2.k
.3k
4...k
300.k'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end