const regex = /^[0-9]+(?:\.(?![km]))?\d*[km]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+(?:\\.(?![km]))?\\d*[km]?$', 'gm')
const str = `400k
400.2k
4m
500.
500000
4.2.k
.3k
4...k
300.k`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}