using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[0-9]+(?:\.(?![km]))?\d*[km]?$";
string input = @"400k
400.2k
4m
500.
500000
4.2.k
.3k
4...k
300.k";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}