package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/[/.\w\s-]+\/[\w@-]+\.(?:jpe?g|gif|png)`)
var str = `https://test.com/image-name@2x.jpeg.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}