const regex = /https?:\/\/[/.\w\s-]+\/[\w@-]+\.(?:jpe?g|gif|png)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https?:\\\/\\\/[\/.\\w\\s-]+\\\/[\\w@-]+\\.(?:jpe?g|gif|png)', 'gm')
const str = `https://test.com/image-name@2x.jpeg.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}