re = /https?:\/\/[\/.\w\s-]+\/[\w@-]+\.(?:jpe?g|gif|png)/m
str = 'https://test.com/image-name@2x.jpeg.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end