$re = '/https?:\/\/[/.\w\s-]+\/[\w@-]+\.(?:jpe?g|gif|png)/m';
$str = 'https://test.com/image-name@2x.jpeg.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);