using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"organizationName.*UTF.+?\s+(.*[^\s]+)\s";
string input = @"organizationName (X.520 DN component) UTF8String Apple inc sdfs dfjgkhkd end";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}