re = /organizationName.*UTF.+?\s+(.*[^\s]+)\s/m
str = 'organizationName (X.520 DN component) UTF8String Apple inc sdfs dfjgkhkd end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end