// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)organizationName.*UTF.+?\s+(.*[^\s]+)\s").unwrap();
let string = "organizationName (X.520 DN component) UTF8String Apple inc sdfs dfjgkhkd end";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}