package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)organizationName.*UTF.+?\s+(.*[^\s]+)\s`)
var str = `organizationName (X.520 DN component) UTF8String Apple inc sdfs dfjgkhkd end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}