using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\[col=([^""]+?)\](.+?)\[\/col\]";
string input = @"[col=Test]
Test
[/col]
[col=Test2]
asd
[/col]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}