$re = '/(?s)\[col=([^"]+?)\](.+?)\[\/col\]/m';
$str = '[col=Test]
Test
[/col]
[col=Test2]
asd
[/col]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);