re = /(?s)\[col=([^"]+?)\](.+?)\[\/col\]/m
str = '[col=Test]
Test
[/col]
[col=Test2]
asd
[/col]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end