package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)\[col=([^"]+?)\](.+?)\[\/col\]`)
var str = `[col=Test]
Test
[/col]
[col=Test2]
asd
[/col]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}