#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:^|>)\s*)[^<>]+May[^<>]+(\s*(?:<|$))"
Local $sString = "<div class='byline'>" & @CRLF & _
" <div>some excerpt</div>" & @CRLF & _
" geplaatst door" & @CRLF & _
" <span class="name">Author's name</span>" & @CRLF & _
" May, 2015" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")