// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:^|>)\s*)[^<>]+May[^<>]+(\s*(?:<|$))").unwrap();
let string = "<div class='byline'>
<div>some excerpt</div>
geplaatst door
<span class=\"name\">Author's name</span>
May, 2015
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}