using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:^|>)\s*)[^<>]+May[^<>]+(\s*(?:<|$))";
string input = @"<div class='byline'>
<div>some excerpt</div>
geplaatst door
<span class=""name"">Author's name</span>
May, 2015
</div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}