package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)[^"]*`)
var str = `"143s (2m 23s)",`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}