$re = '/(\d+)[^"]*/m';
$str = '"143s (2m 23s)",';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;