const regex = /(\d+)[^"]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)[^"]*', 'gm')
const str = `"143s (2m 23s)",`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);