use strict;
my $str = '"143s (2m 23s)",';
my $regex = qr/(\d+)[^"]*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";