#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0\.00)\d{1,3}(,\d{3})*(\.\d\d)?$"
Local $sString = "100.00" & @CRLF & _
"1,000.00" & @CRLF & _
"100,000.00" & @CRLF & _
"1,000,000.00" & @CRLF & _
"00.7" & @CRLF & _
"0.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")