re = /^(?!0\.00)\d{1,3}(,\d{3})*(\.\d\d)?$/m
str = '100.00
1,000.00
100,000.00
1,000,000.00
00.7
0.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end