const regex = /^(?!0\.00)\d{1,3}(,\d{3})*(\.\d\d)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!0\\.00)\\d{1,3}(,\\d{3})*(\\.\\d\\d)?$', 'gm')
const str = `100.00
1,000.00
100,000.00
1,000,000.00
00.7
0.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}