import re
regex = re.compile(r"^(?!0\.00)\d{1,3}(,\d{3})*(\.\d\d)?$", flags=re.MULTILINE)
test_str = ("100.00\n"
"1,000.00\n"
"100,000.00\n"
"1,000,000.00\n"
"00.7\n"
"0.00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")